跳转到主要内容

教程概述

Microsoft Word 已发布近 40 年。从文字录入工具发展为集写作、云端协作、跨平台编辑于一体的办公软件。 注册 PPIO 可获取千万 token 免费额度,用于搭建 Word 续写助手。 下方教程包含完整接入方案(含密钥配置),约 3 分钟完成「Microsoft Word + PPIO API」接入。

配置前置条件

1

获取 API 接口地址

获取 API 接口地址:https://api.ppio.com/openai/v1/chat/completions。
2

创建 API 密钥

登录派欧云控制台 API 密钥管理 页面,点击创建按钮。
3

生成并保存 API 密钥

生成并保存 API 密钥。
密钥在服务端加密存储,请在生成时保存好密钥;若遗失,可在控制台删除并创建一个新的密钥。

4

获取模型 ID

获取需要使用的模型 ID。推荐 DeepSeek 系列模型:
  • DeepSeek V4 Pro:deepseek/deepseek-v4-pro
  • DeepSeek V4.1 Flash:deepseek/deepseek-v4.1-flash
其他模型 ID、最大上下文及价格可参考:模型列表

在 Word 创建开发工具

1

点击【文件】

2

点击【更多】→【选项】

3

启用宏并信任 VBA

点击【信任中心】→【信任中心设置】;在信任中心页面点击【宏设置】→【启用所有宏】→【信任对 VBA 工程对象模型的访问】,全部勾选即可关闭。
4

再次打开【选项】

回到主界面,再点击【文件】→【更多】→【选项】

5

勾选【开发工具】

打开【自定义功能区】——勾选【开发工具】→【确定】
6

打开 Visual Basic

回到主界面,点击【开发工具】→【Visual Basic】
7

点击【插入】→【模块】

8

粘贴代码并填入 API 密钥

复制代码到命令框,仅需修改【api_key = ” ” 】,在” “中填入「生成并保存 API 密钥」步骤中保存的 API 密钥
全部代码如下图:

配置开发工具

1

新建并命名功能组

点击【自定义功能区】→【新建组】,点击【新建组(自定义)】→【重命名】;在显示名称处将自定义名称修改为「PPIO」,【确定】修改名称
2

添加宏命令

点击新建的【PPIO(自定义)】,在命令下拉中选择【宏】→【Project 模块 1】→【添加】→【确定】
3

选中文字生成续写

回到主界面,选中需要续写的文字,点击刚刚创建的模块,Word 中会自动在下列行中输出 PPIO 的 DeepSeek 续写结果。
最后修改于 2026年11月11日